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イベントログ監視がコード 0x800720D9 で失敗する

[サポート情報番号]:000176
[最終更新日]:2010/05/06
[該当製品] :BOM for Windows基本パッケージ 
[バージョン] :5.0 SR3以降

[現象]
イベントログに監視対象のメッセージが書き込まれた際、イベントログ監視がコード 0x800720D9 で失敗する現象が発生いたします。

[詳細]
本現象は、以下のいずれかの手順にて、ログデータの移行を行わなかった場合に発生いたします。


  1. BOM5.0をSR2以前からSR3以降へバージョンアップインストールする際、「ログデータの移行ツールを実行する」というチェックボックスを外した場合

  2. BOM5.0をSR2からSR3以降へバージョンアップする際、一旦SR2をアンインストールした上で、SR3をインストールした場合

[原因]
BOM5.0 SR3では、Windows Server 2008向けのイベントログに対応するため、BOMのログ用データベース形式を拡張しており、BOM5.0SR2以前のデータベースと互換性がありません。
そのため、バージョンアップインストール時にデータベースを変換する移行ツールを実行しております。
ところが、先に挙げた手順を実行してしまうと、移行ツールが実行されないため、古いデータベースのまま動作するため、エラーが発生いたします。


[対処方法]
以下のコマンドを実行し、データベースを更新してください。


  1. スタート→プログラム→アクセサリ→コマンドプロンプトを選択します

  2. フォルダをカレントに設定します

    [BOMインストールディレクトリ]\Bin

    Ex)

    > CD /d “C:\Program Files\SAY Technologies\BOMW5\bin”

  3. 以下の構文でデータ移行ツールを実行します

    BomMigrateEventData.exe –M

  4. 正常にデータ移行が処理されたことを確認します